Intermittent VPN Connection Issues

Incident Report for Canyon View CU

Resolved

A fix has been implemented and this incident has been resolved, if you are still experiencing issues please call Help Desk at 801-463-3580 or submitting a ticket at canyonviewcu.monday.com/portal
Posted Apr 10, 2026 - 10:00 MDT

Investigating

We are currently investigating this issue.
Posted Apr 09, 2026 - 11:21 MDT
This incident affected: VPN.