Daybreak Power Outage

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 14:44 MDT

Identified

Rocky Mountain Power is working on an issue in the area.
Posted Sep 05, 2025 - 14:37 MDT
This incident affected: Power Outage.