Microsoft Having Issues

Incident Report for Canyon View CU

Resolved

This incident has been resolved. If you are still experiencing issues, please contact IT Help Desk by calling us at 801-463-3580 or create a ticket by going to canyonviewcu.monday.com/portal
Posted Jul 23, 2026 - 15:56 MDT

Identified

Vendor Issue: Microsoft across the board is having issues. It affects both Microsoft applications as well as Azure (their server hosting) so other companies are also having issues if they host through Azure. This is causing a variety of issues such as images sent in Teams never load, Meridian Link running slowly, our own website running slowly, and email issues. (IT-12611253155)
Posted Jul 23, 2026 - 10:17 MDT
This incident affected: CanyonViewCU.com Page.