Qualifile Error in MeridianLink

Incident Report for Canyon View CU

Resolved

This incident has been resolved. If you are still experiencing issues, please submit an IT Ticket by going to canyonviewcu.monday.com/portal
Posted Aug 04, 2025 - 14:25 MDT

Investigating

We are currently investigating this issue.
Posted Aug 01, 2025 - 10:43 MDT
This incident affected: Member Applications/Forms.