Card Wizard down

Incident Report for Canyon View CU

Resolved

This incident has been resolved. If you are still experiencing issues with Card Wizard, please reach out to IT Help Desk via Monday.com or by calling "group-IT Help Desk AA" in Teams.
Posted Aug 15, 2025 - 14:18 MDT

Monitoring

A fix has been implemented and we are monitoring the results. If you are still getting an error when trying to get into the Card Wizard site, please try opening the site in an incognito window.
Posted Aug 15, 2025 - 13:47 MDT

Investigating

We are currently investigating this issue. (9830108751)
Posted Aug 15, 2025 - 13:04 MDT
This incident affected: Card System.