Card Wizard Login Issue

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 15:10 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 13:57 MDT

Investigating

Card Wizard is currently not allowing logins. We are working with the vendor to resolve the issue.
Posted Oct 15, 2025 - 12:08 MDT
This incident affected: Card System.