MVi/Laserfiche Down

Incident Report for Canyon View CU

Resolved

This incident has been resolved. If you are still experiencing issues please contact IT Help Desk by calling 801-463-3580 or submitting an IT Ticket at CanyonViewCU.Monday.com/portal
Posted Jan 27, 2026 - 17:32 MST

Investigating

We are currently investigating this issue.
Posted Jan 27, 2026 - 17:09 MST
This incident affected: Laserfiche/MVi.