Check Images in Checking History Missing

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 16:13 MDT

Investigating

In online banking the check images are missing from checking history. We're working to get this fixed, but in the meantime members can go to Services > Check Images and Receipts to find those check images.
Posted Apr 08, 2026 - 10:09 MDT
This incident affected: Member Online Banking.