Emails Down

Incident Report for Canyon View CU

Resolved

This incident has been resolved. If you are still experiencing issues, please contact IT Help Desk by calling us at 801-463-3580 or create a ticket by going to canyonviewcu.monday.com/portal
Posted Jan 23, 2026 - 08:05 MST

Investigating

We are currently investigating this issue.
Posted Jan 22, 2026 - 13:13 MST
This incident affected: Email.