Card Manager Outage

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 08:59 MDT

Investigating

We're experiencing an outage with the Card Manager section in OB, we're working with the vendor for a fix.
Posted Oct 20, 2025 - 12:26 MDT
This incident affected: Member Online Banking.