CSR Assist Experiencing Issues

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 11:03 MDT

Investigating

There is an ongoing issue with employees not being able to see accounts on the member's homepage when they CSR Assist into their account. This is only effecting employees with "view only" rights. We're working with the vendor on a solution.
Posted Aug 06, 2025 - 16:36 MDT
This incident affected: Employee Banking Systems.