Quickbooks Canyon View Connection Error

Incident Report for Canyon View CU

Resolved

This incident has been resolved. Please contact IT Help Desk if you are still experiencing issues.
Posted Aug 29, 2025 - 16:10 MDT

Investigating

Members using Quickbooks are encountering an error preventing them from connecting their Canyon View Account. We're working with the vendor to find a solution
Posted Aug 28, 2025 - 12:16 MDT
This incident affected: Member Online Banking.