Credit Score Monitoring Outage

Incident Report for Canyon View CU

Resolved

This incident has been resolved. Please contact IT Help Desk if you are still experiencing issues.
Posted Nov 26, 2025 - 09:48 MST

Update

This incident has been resolved. Please contact IT Help Desk if you are still experiencing issues.
Posted Nov 10, 2025 - 11:50 MST

Investigating

Credit Score Monitoring in online banking is currently down, we're working with our vendor for a solution, will update as soon as this is resolved. IT 18244809609
Posted Oct 22, 2025 - 09:25 MDT
This incident affected: Member Online Banking.