Card Wizard Issues

Incident Report for Canyon View CU

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 12:00 MDT

Investigating

We are actively working on resolving the issue.
Posted Aug 11, 2025 - 11:38 MDT
This incident affected: Card System.